Ce matin, pas moyen de mettre à jour le système (Debian GNU/Linux Stretch) :

$ sudo apt-full-upgrade
# (...)
Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 37, in <module>
    import apt_listchanges, DebianFiles, ALCApt, ALCConfig, ALCSeenDb
  File "<frozen importlib._bootstrap>", line 969, in _find_and_load
  File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 673, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 669, in exec_module
  File "<frozen importlib._bootstrap_external>", line 773, in get_code
  File "<frozen importlib._bootstrap_external>", line 484, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
# (...)

J'ai utilisé cette solution qui a fonctionné :

sudo find /usr -name '*.pyc' -delete